Ladies and Gentlemen,
We have a unique challenge that we're trying to address using fsvs.  We have a lot of servers out "in the wild" as it were, and instead of using some sort of package management system to upgrade the OS and our own software, we want to use fsvs.

The idea is that we can make updates on our own master server, check them into fsvs/subversion, and then have each of the "in the wild" servers update from fsvs/subversion.  This seems like a great idea, but we've had a bit of difficulty when trying to actually get these updates to work.

In our testing environment, we'll make some changes and then commit them fine, but when we try to do an update, we will often (but not always) get something like the following:

dev-01 / # fsvs update -r 19
Updating svn+ssh://user@svnserver//home/user/svn/osrepo to revision        19.
The entry ./etc/fsvs has changed locally

We've tried with and without the "-r <revision>", and we don't always get the same file as having changed (though it is usually one of a handful of files).  I'm fairly certain that the file in question has not in fact changed.  One thing we've tried is doing a revert just before an update, but that doesn't seem to fix it.

We really like fsvs, from a conceptual level, and it seems like the right solution, but this has us pulling our hair out.  Can anyone shine any light on the situation?  Is this an imporper use of this package?  Are we missing something obvious?  I can elaborate on our setup and such, if that would be helpful, but I don't want to dump a bunch of configs on this list if it isn't necessary.

Thanks in advance for any insight you can offer,
Stu