Hi again Phil !

2011/6/25 Philipp Marek <philipp@marek.priv.at>
Hello Frode!


> Now gmake fails much later:
...
> /home/froh/sw/src/fsvs-1.2/src/fsvs.c:476: undefined reference to `fmemopen'
Well, this should be seen during configure - HAVE_FMEMOPEN - and then just the
debug-buffer options should be disabled during compilation.

You could try --enable-release - this would remove all debug print calls (although the
function would have to be removed by the linker). But that shouldn't be necessary!

 
That worked, and adding this to configure also worked:
if [ `uname -s` = "OpenBSD" ]
then
        # OSX 10.6 - thanks, Florian.
        EXTRALIBS="-liconv"
        have_fmemopen=no
fi


> /home/froh/sw/src/fsvs-1.2/src/helper.c:1436: undefined reference to
> `iconv_open'
...
> From a quick web search it seems fmemopen is a glibc only
>
> I did some testing of openbsd's iconv, as suggested in this thread:
> https://bitbucket.org/medoc/recoll/issue/61/configure-on-openbsd-fails-on-iconv
...
> $ gcc iconvtest.c
> iconvtest.c:8: error: conflicting types for 'libiconv_open'
> /usr/local/include/iconv.h:73: error: previous declaration of
> 'libiconv_open' was here
Well, this is a compile error; with FSVS it's a linker problem.

 
Perhaps this is an artifact of not running configure again after the update; please
re-run "make clean", "configure", and "make".

Thanks, but I always do this when  recompiling.

I talked to a Mr. "NicM" on #openbsd@freenode, who identified a use of iconv_open outside #ifdef HAVE_LOCALES in helper.c

Then i supected HAVE_LOCALES was not set, and commented out the ifdef around  #include <iconv.h>
Now fsvs compiles.

--
Frode Haugsgjerd
Norway