Login | Register
My pages Projects Community openCollabNet

Discussions > dev > RE: FTBFS 1.2.0 on Solaris 10

fsvs
Discussion topic

Back to topic list

RE: FTBFS 1.2.0 on Solaris 10

Author pmarek
Full name P.Marek
Date 2009-07-24 04:34:37 PDT
Message Hello Mark!

> I just realized the difference here... if I run configure as root I get
> the libgdbm error, if I run it as myself I get the libapr-util-1 error.
> This is repeatable, but doesn't make much sense to me...
Could you compare your environments for root and user? Maybe you've got different
CFLAGS/LDFLAGS or whatever; maybe some directory is unreadable for the user?

Could you try tracing the configure call with strace (my default options are "-f -tt -o
/tmp/some-filename"), and look where they differ?
Perhaps for the first run it would make sense to only list the open calls (with "-e
open"), too see what the compiler does differently.


Regards,

Phil

--
Versioning your /etc, /home or even your whole installation?
             Try fsvs (fsvs.tigris.org)!

« Previous message in topic | 6 of 6 | Next message in topic »

Messages

Show all messages in topic

RE: FTBFS 1.2.0 on Solaris 10 "Petersen, Mark" <MPetersen at gs1us dot org> "Petersen, Mark" <MPetersen at gs1us dot org> 2009-07-23 06:05:21 PDT
     Re: FTBFS 1.2.0 on Solaris 10 pmarek P.Marek 2009-07-23 06:50:58 PDT
         RE: FTBFS 1.2.0 on Solaris 10 "Petersen, Mark" <MPetersen at gs1us dot org> "Petersen, Mark" <MPetersen at gs1us dot org> 2009-07-23 07:59:50 PDT
             RE: FTBFS 1.2.0 on Solaris 10 "Petersen, Mark" <MPetersen at gs1us dot org> "Petersen, Mark" <MPetersen at gs1us dot org> 2009-07-23 08:18:19 PDT
                 RE: FTBFS 1.2.0 on Solaris 10 "Petersen, Mark" <MPetersen at gs1us dot org> "Petersen, Mark" <MPetersen at gs1us dot org> 2009-07-23 08:27:22 PDT
                     RE: FTBFS 1.2.0 on Solaris 10 pmarek P.Marek 2009-07-24 04:34:37 PDT
Messages per page: