Login | Register
My pages Projects Community openCollabNet

Discussions > dev > FTBFS Solaris 10

fsvs
Discussion topic

Back to topic list

FTBFS Solaris 10

Author "Petersen, Mark" <MPetersen at gs1us dot org>
Full name "Petersen, Mark" <MPetersen at gs1us dot org>
Date 2009-09-23 12:40:35 PDT
Message So I'm trying to do this again. I got the configure to run this time
with just a couple WARNINGS.

--
config.status: WARNING: 'src/Makefile.in' seems to ignore the
--datarootdir setting
config.status: creating tests/Makefile
config.status: creating src/config.h
config.status: src/config.h is unchanged
configure: WARNING:
  * MAJOR(), MINOR() and MAKEDEV() definitions not found.
  * Fake a definition, but that could make problems for ignore patterns
  * and commits/updates of device nodes, so these will be disabled.
  * Please contact dev at fsvs dot tigris dot org for help, or, if you know your
  * systems' way, to report the correct header name.
  *
  * If you *really* need to use device compares, and have *no* other
way,
  * you could try using the --enable-dev-fake option on ./configure.
--

I get these even when I use the --enable-dev-fake option.

Then I run into some path/LD_LIBRARY issues that I think I resolved.
Make runs for awhile (with a lot of warnings) and then blows up:

waa.c: In function `waa__find_common_base2':
waa.c:2299: warning: 'path2copy' might be used uninitialized in this
function
waa.c:2299: warning: 'basepath2copy' might be used uninitialized in this
function
waa.c:2304: warning: 'fnlen' might be used uninitialized in this
function
     CC warnings.c
     Link fsvs
Undefined first referenced
 symbol in file
fmemopen fsvs.o
libiconv_open helper.o (symbol belongs to
implicit dependency /usr/local/lib/libiconv.so.2)
libiconv helper.o (symbol belongs to
implicit dependency /usr/local/lib/libiconv.so.2)
ld: fatal: Symbol referencing errors. No output written to fsvs
collect2: ld returned 1 exit status
make[1]: *** [fsvs] Error 1
make: *** [default-target] Error 2


I think is Solaris related, but I'm hoping you can point me in the right
direction to overcome this or perhaps just get more details about what
went wrong. Hopefully I can get fsvs running on Solaris soon...

Thanks,
Mark

« Previous message in topic | 1 of 7 | Next message in topic »

Messages

Show all messages in topic

FTBFS Solaris 10 "Petersen, Mark" <MPetersen at gs1us dot org> "Petersen, Mark" <MPetersen at gs1us dot org> 2009-09-23 12:40:35 PDT
     Re: FTBFS Solaris 10 pmarek P.Marek 2009-09-23 23:41:21 PDT
         RE: FTBFS Solaris 10 "Petersen, Mark" <MPetersen at gs1us dot org> "Petersen, Mark" <MPetersen at gs1us dot org> 2009-09-24 07:44:53 PDT
             RE: FTBFS Solaris 10 "Petersen, Mark" <MPetersen at gs1us dot org> "Petersen, Mark" <MPetersen at gs1us dot org> 2009-09-24 08:11:18 PDT
                 RE: FTBFS Solaris 10 pmarek P.Marek 2009-09-24 23:03:53 PDT
                     RE: FTBFS Solaris 10 "Petersen, Mark" <MPetersen at gs1us dot org> "Petersen, Mark" <MPetersen at gs1us dot org> 2009-09-25 07:43:50 PDT
                         Re: FTBFS Solaris 10 pmarek P.Marek 2009-09-25 09:21:46 PDT
Messages per page: