Login | Register
My pages Projects Community openCollabNet

Discussions > dev > Versions 1.0.14 and up return configure: WARNING

fsvs
Discussion topic

Back to topic list

Versions 1.0.14 and up return configure: WARNING

Author benjaminm
Full name Benjamin M.
Date 2007-01-28 10:28:58 PST
Message Hi Phil!

Long time no see!

I've move one server under CentOS 4.4 and since version 1.0.14 I get
"configure: WARNING" and make refuses to work. With 1.0.13 configure
works but make makes an error. See below.

Any idea?

Ben.

--

$ pwd
/tmp/fsvs-1.0.14/src
$ ./configure

<snip>
configure: WARNING: fcntl.h: present but cannot be compiled
configure: WARNING: fcntl.h: check for missing prerequisite headers?
configure: WARNING: fcntl.h: see the Autoconf documentation
configure: WARNING: fcntl.h: section "Present But Cannot Be Compiled"
configure: WARNING: fcntl.h: proceeding with the preprocessor's result
configure: WARNING: fcntl.h: in the future, the compiler will take
precedence
configure: WARNING: ## --------------------​------------------ ##
configure: WARNING: ## Report this to http://fsvs.tigris.org/ ##
configure: WARNING: ## --------------------​------------------ ##
<snip>
configure: WARNING: stddef.h: present but cannot be compiled
configure: WARNING: stddef.h: check for missing prerequisite headers?
configure: WARNING: stddef.h: see the Autoconf documentation
configure: WARNING: stddef.h: section "Present But Cannot Be Compiled"
configure: WARNING: stddef.h: proceeding with the preprocessor's result
configure: WARNING: stddef.h: in the future, the compiler will take
precedence
configure: WARNING: ## --------------------​------------------ ##
configure: WARNING: ## Report this to http://fsvs.tigris.org/ ##
configure: WARNING: ## --------------------​------------------ ##
<snip>
configure: WARNING: sys/time.h: present but cannot be compiled
configure: WARNING: sys/time.h: check for missing prerequisite headers?
configure: WARNING: sys/time.h: see the Autoconf documentation
configure: WARNING: sys/time.h: section "Present But Cannot Be Compiled"
configure: WARNING: sys/time.h: proceeding with the preprocessor's result
configure: WARNING: sys/time.h: in the future, the compiler will take
precedence
configure: WARNING: ## --------------------​------------------ ##
configure: WARNING: ## Report this to http://fsvs.tigris.org/ ##
configure: WARNING: ## --------------------​------------------ ##

etc..


$ pwd
/tmp/fsvs-1.0.13/src
$ ./configure
$ make

<snip>

cc -Wall -funsigned-char -D_GNU_SOURCE=1 -D_FILE_OFFSET_BITS=64
-idirafter /usr/local/include -idirafter /usr/include -idirafter
/openpkg/include -idirafter /usr/local/include/apr-0 -idirafter
/usr/include/apr-0 -idirafter /openpkg/include/apr-0 -idirafter
/usr/local/include/apr-1 -idirafter /usr/include/apr-1 -idirafter
/openpkg/include/apr-1 -Os -DFSVS_VERSION='"fsv​s-1.0.13:396"' -c -o
warnings.o warnings.c
cc -L/usr/local/lib -L/openpkg/lib -lsvn_subr-1 -lsvn_ra-1
-lsvn_client-1 -lpcre fsvs.o ac_list.o actions.o add_unvers.o build.o
checksum.o commit.o direnum.o est_ops.o export.o helper.o ignore.o
info.o init.o pwcache.o racallback.o remote.o status.o sync.o update.o
waa.o warnings.o -o fsvs
/usr/local/subversio​n-1.4.2/lib/libsvn_r​a_dav-1.so.0: undefined
reference to `gss_import_name'
/usr/local/subversio​n-1.4.2/lib/libsvn_r​a_dav-1.so.0: undefined
reference to `gss_release_name'
/usr/local/subversio​n-1.4.2/lib/libsvn_r​a_dav-1.so.0: undefined
reference to `gss_delete_sec_context'
/usr/local/subversio​n-1.4.2/lib/libsvn_r​a_dav-1.so.0: undefined
reference to `gss_display_status'
/usr/local/subversio​n-1.4.2/lib/libsvn_r​a_dav-1.so.0: undefined
reference to `gss_release_buffer'
/usr/local/subversio​n-1.4.2/lib/libsvn_r​a_dav-1.so.0: undefined
reference to `gss_init_sec_context'
/usr/local/subversio​n-1.4.2/lib/libsvn_r​a_dav-1.so.0: undefined
reference to `GSS_C_NT_HOSTBASED_SERVICE'
collect2: ld returned 1 exit status
make: *** [fsvs] Error 1

« Previous message in topic | 1 of 13 | Next message in topic »

Messages

Show all messages in topic

Versions 1.0.14 and up return configure: WARNING benjaminm Benjamin M. 2007-01-28 10:28:58 PST
     Re: Versions 1.0.14 and up return configure: WARNING pmarek P.Marek 2007-01-28 11:33:49 PST
         Re: Versions 1.0.14 and up return configure: WARNING benjaminm Benjamin M. 2007-01-28 13:25:23 PST
             Re: Versions 1.0.14 and up return configure: WARNING pmarek P.Marek 2007-01-30 07:52:14 PST
                 Re: Versions 1.0.14 and up return configure: WARNING benjaminm Benjamin M. 2007-01-30 10:31:42 PST
                     Re: Versions 1.0.14 and up return configure: WARNING pmarek P.Marek 2007-01-30 22:31:19 PST
                         Re: Versions 1.0.14 and up return configure: WARNING benjaminm Benjamin M. 2007-01-31 08:17:53 PST
                             Re: Versions 1.0.14 and up return configure: WARNING pmarek P.Marek 2007-01-31 23:47:30 PST
                                 Re: Versions 1.0.14 and up return configure: WARNING benjaminm Benjamin M. 2007-02-01 07:32:04 PST
                                     Re: Versions 1.0.14 and up return configure: WARNING pmarek P.Marek 2007-02-01 09:03:45 PST
                                         Re: Versions 1.0.14 and up return configure: WARNING benjaminm Benjamin M. 2007-02-01 11:24:23 PST
                                             Re: Versions 1.0.14 and up return configure: WARNING pmarek P.Marek 2007-02-01 22:19:03 PST
                                                 Re: Versions 1.0.14 and up return configure: WARNING benjaminm Benjamin M. 2007-02-02 06:19:41 PST
Messages per page: