Login | Register
My pages Projects Community openCollabNet

Discussions > dev > Re: FSVS: ./configure failed since 1.1.7 (CentOS 5)

fsvs
Discussion topic

Back to topic list

Re: FSVS: ./configure failed since 1.1.7 (CentOS 5)

Author pmarek
Full name P.Marek
Date 2007-08-26 01:33:00 PDT
Message On Saturday 25 August 2007 Benjamin M. wrote:
> No problem with 1.1.6 but since 1.1.7 I get the following error on
> ./configure. Any idea?
>
> # ./configure --prefix=/usr/local/fsvs-1.1.8
> configure: *** Now configuring FSVS ***
> checking for gcc... gcc
> checking for C compiler default output file name... a.out
> checking whether the C compiler works... yes
> checking whether we are cross compiling... no
> checking for suffix of executables...
> checking for suffix of object files... o
> checking whether we are using the GNU C compiler... yes
> checking whether gcc accepts -g... yes
> checking for gcc option to accept ISO C89... none needed
> checking how to run the C preprocessor... gcc -E
> ./configure: line 2904: apr-config: command not found
> <----------------- ??????
configure.in has
    AC_ARG_WITH(aprinc,
        AC_HELP_STRING([--wi​th-aprinc=PATH],
          [Specify an include directory for the APR headers.]),
        [
          INCDIRS="$INCDIRS $withval"
        ], [
          if APR=`apr-config --includedir`
          then
            INCDIRS="$INCDIRS $APR"
          fi
        ])
which should take a --with-aprinc=<path> parameter, or, if
none set, should run the program "apr-config" and try to
get the path from there.

You didn't give a path, and apr-config could not be found.
> Where apr-config is supposed to come from?
>
> # locate apr-config
> /usr/src/apr-1.2.9/a​pr-config.in
> /usr/src/apr-1.2.9/a​pr-config.out
>
> CentOS 5.0
>
> apr-1.2.9
> apr-iconv-1.2.0
> apr-util-1.2.8
I have
    $ dpkg-query -S apr-config
    libapr1-dev: /usr/share/man/man1/​apr-config.1.gz
    libapr1-dev: /usr/bin/apr-config
so you might be missing a development package.


> configure: "CFLAGS=-g -O2 -D_GNU_SOURCE=1 -D_FILE_OFFSET_BITS=64
> -idirafter /usr/local/include -idirafter /usr/include -idirafter
> /openpkg/include"
> configure: "LDFLAGS= -L/usr/local/lib -L/openpkg/lib"
> checking for pcre_compile in -lpcre... yes
> checking for apr_md5_init in -laprutil-1... yes
> checking for svn_ra_initialize in -lsvn_ra-1... no <-----------------
> ?????? configure: error: Sorry, can't find subversion.
> See `config.log' for more details.
> autoconf-2.61
> subversion-1.4.4 (with-ssl)
Same here, I think:
    $ dpkg-query -S apr-config
    libapr1-dev: /usr/share/man/man1/​apr-config.1.gz
    libapr1-dev: /usr/bin/apr-config

On the frontpage http://fsvs.tigris.org/ is written:
    For CentOS5 (and probably RHEL5) I got this line from a user:
    yum install subversion subversion-devel ctags apr apr-devel gcc gdbm gdbm-devel pcre pcre-devel
 

Sorry, but did you read the documentation ;-?

Hope it's only that.


Regards,

Phil


--
Versioning your /etc, /home or even your whole installation?
             Try fsvs (fsvs.tigris.org)!

« Previous message in topic | 2 of 6 | Next message in topic »

Messages

Show all messages in topic

FSVS: ./configure failed since 1.1.7 (CentOS 5) benjaminm Benjamin M. 2007-08-25 12:58:03 PDT
     Re: FSVS: ./configure failed since 1.1.7 (CentOS 5) pmarek P.Marek 2007-08-26 01:33:00 PDT
         Re: FSVS: ./configure failed since 1.1.7 (CentOS 5) benjaminm Benjamin M. 2007-08-26 10:59:44 PDT
             Re: FSVS: ./configure failed since 1.1.7 (CentOS 5) pmarek P.Marek 2007-08-26 11:31:32 PDT
                 Re: FSVS: ./configure failed since 1.1.7 (CentOS 5) benjaminm Benjamin M. 2007-08-26 17:28:31 PDT
                     Re: FSVS: ./configure failed since 1.1.7 (CentOS 5) pmarek P.Marek 2007-08-27 10:08:02 PDT
Messages per page: