Login | Register
My pages Projects Community openCollabNet

Discussions > dev > Solaris Issues

fsvs
Discussion topic

Hide all messages in topic

All messages in topic

Re: Solaris Issues

Author pmarek
Full name P.Marek
Date 2009-02-10 09:25:38 PST
Message
Attachments

Re: Solaris Issues

Author pmarek
Full name P.Marek
Date 2009-02-10 09:12:08 PST
Message
Attachments

Re: Solaris Issues

Author pmarek
Full name P.Marek
Date 2009-02-06 07:39:19 PST
Message
Attachments

Re: Solaris Issues

Author pmarek
Full name P.Marek
Date 2009-02-06 05:17:30 PST
Message
Attachments

Solaris Issues

Author pjodrr at gmail dot com
Full name pjodrr at gmail dot com
Date 2009-02-06 03:42:04 PST
Message Hello!

I really would like to try fsvs but
unfortunately I cannot get it to run under
Solaris 10 without dumping core. Here is a
list of problems I encountered (I use v1.1.17):
1. src/config.h needs
   #define NAME_MAX (FILENAME_MAX)
   that has been reported before but is not
   included in the source distribution
2. Solaris does not have strsep() so I had
   to include a replacement, as mentioned in
   http://www.winehq.or​g/pipermail/wine-pat​ches/2001-November/0​01322.html
3. the Makefile does not use $(DESTDIR) but
   that is required for packaging
4. "make install" uses "cp -a" but "-a"
   is no option to "cp" on Solaris
5. in src/options.c replace this:
   .name="softroot", .cp_val=NULL, .parse=opt___normalized_path,
   with that:
   .name="softroot", .cp_val="", .parse=opt___normalized_path,
   otherwise fsvs will dump core on initialization

It took me a day to find out the above and
now at least I can run "fsvs help" without
error.

Cheers!

  Peter

ps: I'm not subscribed
Messages per page: