Login | Register
My pages Projects Community openCollabNet

Discussions > issues > [Issue 6] New - fsvs 1.1.17 ignores some of "config"'s configuration directives

fsvs
Discussion topic

Back to topic list

[Issue 6] New - fsvs 1.1.17 ignores some of "config"'s configuration directives

Author farzy
Full name Farzad FARID
Date 2008-11-03 06:24:55 PST
Message http://fsvs.tigris.o​rg/issues/show_bug.c​gi?id=6
                 Issue #|6
                 Summary|fsvs 1.1.17 ignores some of "config"'s configuration d
                        |irectives
               Component|fsvs
                 Version|current
                Platform|Linux
              OS/Version|All
                     URL|
                  Status|NEW
       Status whiteboard|
                Keywords|
              Resolution|
              Issue type|DEFECT
                Priority|P3
            Subcomponent|user interface
             Assigned to|pmarek
             Reported by|farzy






------- Additional comments from farzy at tigris dot org Mon Nov 3 06:24:55 -0800 2008 -------
Using fsvs 1.1.17 on RHEL 4. I'm versionning "/etc".

"config" file contains (comments excluded):
  author=easynet
  empty_commit=no
  stat_color=yes
  filter=none,text,new​,deleted,group,owner​
  config_dir=/root/.subversion

I first make sur that SVN stores the user/password in cache :

# svn --username=easynet ls svn://10.10.2.44/system/...
Authentication realm: <svn://10.10.2.44:3690> Referentiel
Password for 'easynet': ****


1) Following the man pages, I create the "config" file in the $FSVS_CONF/wc-dir/
directory (in my case /etc/fsvs/182f153bd9​4803955c2043e6f2581d​5d/config)

Now with FSVS:
# cd /etc
# fsvs log
Authentication realm: <svn://10.10.2.44:3690> Referentiel
Password for 'root':

FSVS asks me for root's password instead of using the "easynet" account.

2) I move the config file one directory up, in "/etc/fsvs/config"

# fsvs log
Authentication realm: <svn://10.10.2.44:3690> Referentiel
Password for 'easynet':

This time it correctly uses the "easynet" account that I added in the config file.

BUT: it asks me for the password, instead of using SVN's auth cache.

3) I create the following symlink:

# ln -s /root/.subversion /etc/fsvs/auth

Now:
# fsvs log
[... log entries...]

This time FSVS correctly uses the SVN auth cache.

So there are apparently 2 problems with FSFS 1.1.17 here:

- The config file is at least partially ignored when it is in
"$FSVS_CONF/wc-dir/config" (/etc/fsvs/182f153bd​94803955c2043e6f2581​d5d here):
"author" does not work. It works if the config file is in "/etc/fsvs".

- The "config_dir" directory does not work, even in the 2nd case, I had to
create an "auth" symlink in the "/etc/fsvs" directory in order to use the SVN
auth cache.

« Previous message in topic | 1 of 4 | Next message in topic »

Messages

Show all messages in topic

[Issue 6] New - fsvs 1.1.17 ignores some of "config"'s configuration directives farzy Farzad FARID 2008-11-03 06:24:55 PST
     [Issue 6] fsvs 1.1.17 ignores some of "config"'s configuration directives farzy Farzad FARID 2008-11-03 06:58:40 PST
     [Issue 6] fsvs 1.1.17 ignores some of "config"'s configuration directives pmarek P.Marek 2008-11-03 23:38:54 PST
     [Issue 6] fsvs 1.1.17 ignores some of "config"'s configuration directives pmarek P.Marek 2010-01-04 14:42:43 PST
Messages per page: