Login | Register
My pages Projects Community openCollabNet

Discussions > users > Re: fsvs 1.2.0-Problem

fsvs
Discussion topic

Back to topic list

Re: fsvs 1.2.0-Problem

Author pmarek
Full name P.Marek
Date 2009-08-17 04:37:40 PDT
Message [ Gunter had problems getting this mail to the list, so I'm forwarding for him. ]
> (I resubmitted this mail from 2009-07-25 again as it did not show up in
> the ML archives so far and my resubmission from 2009-08-06 also seems to
> have been lost, I apologize if you receive it more than once.)


> After quite some time I decided to take a look at updating my fsvs from
> 1.1.5 to 1.2.0, but just ended up scratching my head...
>
> To avoid problems caused by legacy data, I planned to restart with fresh
> fsvs WAA directories and a "sync-repos".
>
> Alas, when I tried to connect to my repository, which I do using http
> and
> basic auth via an ssh-port-forwarded tunnel, I just got the following
> error, while access works fine with svn itself and my old fsvs 1.1.5
> binary.
>
> *************************
> # FSVS_WAA=$HOME/.fsvs-1.2/waa FSVS_CONF=$HOME/.fsvs-1.2/conf fsvs-1.2.0
> \
> sync-repos
> Anmeldebereich: <http://127.0.0.1:8080> Backuprepo
>
>
> An error occurred: Autorisierung schlug fehl (170001)
> in url__open_session: svn_ra_open("http://127.0.0.1:8080/home"):
> OPTIONS
> von »http://127.0.0.1:8080/home«: Autorisierung schlug fehl: Could not
> authenticate to server: rejected Basic challenge (http://127.0.0.1:8080)
>
> # svn ls 'http://localhost:808​0/home/.kde/'
> share/
>
> # _
> *************************
>
> Just out of the blue I retried the sync-repos in the "C" locale, and
> guess
> what, authorization worked and the sync-repos started until it ran into
> encoding problems... My standard locale is de_DE@euro (ISO-8859-15).
That's strange.

> I had the best experience with the en_DB (ISO-8859-1) locale, where the
> sync-repos seems to get very far. However, fsvs does not remember my
> login
> credentials and asks for my password every time I connect to the
> repository.
Did you create the authentication directories, as in the "install" target of the
Makefile? (broken because of mailer)

  install:
        mkdir -p /etc/fsvs /var/spool/fsvs $(bindir)
                  /etc/fsvs/auth/svn.simple /etc/fsvs/auth/svn.ssl.server

That's needed so that the subversion libraries have a place to store the authentication
data.

Alternatively you could try to use
    FSVS_WAA= .... fsvs -o config_dir=$HOME/.subversion/ sync-repos

That should use the already stored data.

> I said, using the en_GB locale sync-repos got pretty far: Yes, it seems
> to
> successfully sync all remote files but exits with an error while
> finalizing:
>
> *************************
> (Yada-yada...)
> ..C. 0 .
>
>
> An error occurred: Filesystem has no item (160013)
> in rev__get_text_to_stream: Fetching entry
> http://127.0.0.1:808​0/home/.kde4@676:
> 'http://subversion.ti​gris.org/xmlns/dav/m​d5-checksum' was not present on
> the resource
> *************************
Hmmm ... my http/https DAV testing is very limited.
Possibly it needs some information that FSVS doesn't currently provide?

Could you re-run with -d, and send me the last 20 lines, please?


> fsvs-1.2.0 is compiled against Subversion 1.6.3 libraries (Debian SID)
> while the server is Subversion 1.5.1 (Debian Lenny), accessing an
> unconverted repository created by Subversion 1.4.x (Debian Etch).
>
> Does anyone have any idea what's going wrong, both with login
> authorisation in the de_DE@euro locale and with sync-repos?
Not yet ;-)

As you're using http://localhost, does a sync-repos work for file:///?


Regards,

Phil

--
Versioning your /etc, /home or even your whole installation?
             Try fsvs (fsvs.tigris.org)!

« Previous message in topic | 1 of 3 | Next message in topic »

Messages

Show all messages in topic

Re: fsvs 1.2.0-Problem pmarek P.Marek 2009-08-17 04:37:40 PDT
     Re: fsvs 1.2.0-Problem Gunter Ohrner <Gunter at ohrner dot net> Gunter Ohrner <Gunter at ohrner dot net> 2009-08-27 11:55:19 PDT
         Re: fsvs 1.2.0-Problem pmarek P.Marek 2009-08-27 23:18:55 PDT
Messages per page: