Login | Register
My pages Projects Community openCollabNet

Discussions > users > Re: fsvs 1.2.0-Problem

fsvs
Discussion topic

Back to topic list

Re: fsvs 1.2.0-Problem

Author pmarek
Full name P.Marek
Date 2009-08-27 23:30:51 PDT
Message > # fsvs-1.2.0 -d sync-repos
...
> 20:55:20.255 hlp___do_convert[helper.c:185] converted .kde4 to .kde4
>
>
> An error occurred at 20:55:21.957: Filesystem has no item (160013)
> in rev__get_text_to_stream [revert.c:301]: Fetching entry
> http://127.0.0.1:808​0/home/.kde4@686:
> 'http://subversion.ti​gris.org/xmlns/dav/m​d5-checksum' was not present on
> the resource
> 20:55:21.956 main[fsvs.c:1413] memory stats: 0x8368000 to 0xdc31000, 90916
> KB
That looks normal; there's not even any special character in the name.

This error message was recently improved, see here:
  http://svn.haxx.se/d​ev/archive-2009-06/0​254.shtml

Others (svn, tsvn, ....) seem to get the same message when merging from the wrong path.
But the path is not wrong per se ... it could be that *this entry* wasn't changed at
that revision, but that shouldn't matter.


Ah, I just found something: This entry might be a directory, but FSVS tries to fetch the
textual data - which only works for files!

It says "a symlink" ... what is that .kde4 really? In the repository, and in the
filesystem?

Would you please send me the debug file of
  fsvs sync-repos -o debug_output="|grep -F .kde4 > /tmp/debug.txt" -d


Thank you; I'll do some testing.


Regards,

Phil

--
Versioning your /etc, /home or even your whole installation?
             Try fsvs (fsvs.tigris.org)!

« Previous message in topic | 1 of 2 | Next message in topic »

Messages

Show all messages in topic

Re: fsvs 1.2.0-Problem pmarek P.Marek 2009-08-27 23:30:51 PDT
     Re: fsvs 1.2.0-Problem Gunter Ohrner <G dot Ohrner at post dot rwth-aachen dot de> Gunter Ohrner <G dot Ohrner at post dot rwth-aachen dot de> 2009-08-28 00:18:57 PDT
Messages per page: