Login | Register
My pages Projects Community openCollabNet

Discussions > users > Re: fsvs 1.2.0-Problem

fsvs
Discussion topic

Back to topic list

Re: fsvs 1.2.0-Problem

Author Gunter Ohrner <G dot Ohrner at post dot rwth-aachen dot de>
Full name Gunter Ohrner <G dot Ohrner at post dot rwth-aachen dot de>
Date 2009-08-28 00:18:57 PDT
Message Am Freitag, 28. August 2009 schrieb Philipp Marek:
> > # fsvs-1.2.0 -d sync-repos
> > (...)
> > 20:55:20.255 hlp___do_convert[helper.c:185] converted .kde4 to .kde4
> > (...)
> > An error occurred at 20:55:21.957: Filesystem has no item (160013)
> > in rev__get_text_to_stream [revert.c:301]: Fetching entry
> > http://127.0.0.1:808​0/home/.kde4@686:
> > 'http://subversion.ti​gris.org/xmlns/dav/m​d5-checksum' was not present
> > on the resource

> Ah, I just found something: This entry might be a directory, but FSVS
> tries to fetch the textual data - which only works for files!

> It says "a symlink" ... what is that .kde4 really? In the repository,
> and in the filesystem?

Hit - you spotted it. Thanks.

~/.kde4 is a symlink to ~/.kde in the filesystem, but is a real directory
in the repository. It originally was a directory and I changed it to a
symlink sometime later.

I did not encounter this problem with the previous version of fsvs as I
only commit certain subdirectories of my home since quite some time,
because the older fsvs version I used chokes on some other directories.

I'm trying to upgrade to fsvs 1.2 just to see whether this will solve
these problems. ;)

So we're experiencing another classical case of PEBKAC, but fsvs' error
message could be improved.

Greetings,

  Gunter
Attachments

« Previous message in topic | 2 of 2 | Next message in topic »

Messages

Show all messages in topic

Re: fsvs 1.2.0-Problem pmarek P.Marek 2009-08-27 23:30:51 PDT
     Re: fsvs 1.2.0-Problem Gunter Ohrner <G dot Ohrner at post dot rwth-aachen dot de> Gunter Ohrner <G dot Ohrner at post dot rwth-aachen dot de> 2009-08-28 00:18:57 PDT
Messages per page: