Login | Register
My pages Projects Community openCollabNet

Discussions > users > Re: FSVS on Mac OS X 10.6

fsvs
Discussion topic

Back to topic list

Re: FSVS on Mac OS X 10.6

Author xmirakulix
Full name Florian
Date 2010-07-01 14:29:40 PDT
Message Hello Phil,

> I'd suggest just adding "-lapr-1 -laprutil-1" to the "EXTRALIBS" line in the Makefile;

which was exactly what was needed, as well as iconv.

I simply changed changed configure to:
EXTRALIBS="-laprutil-1 -lapr-1 -liconv"

FYI, on my Mac, uname -a evaluates to "Darwin"

Then I had to manually set have_fmemopen to no, because it seems that the code that should test this, doesn't work here.

But thanks to your effort, I have a fsvs binary now, which was able to checkout a repo on my first test right now.

If you want, I'll be happy to provide a tester for any changes you may make to fsvs regarding Mac OS compatibility.

Regards,
Florian

« Previous message in topic | 7 of 8 | Next message in topic »

Messages

Show all messages in topic

FSVS on Mac OS X 10.6 xmirakulix Florian 2010-06-30 09:02:25 PDT
     Re: FSVS on Mac OS X 10.6 pmarek P.Marek 2010-06-30 09:56:06 PDT
         RE: Re: FSVS on Mac OS X 10.6 xmirakulix Florian 2010-06-30 12:03:16 PDT
             RE: Re: FSVS on Mac OS X 10.6 pmarek P.Marek 2010-07-01 00:01:17 PDT
                 Re: FSVS on Mac OS X 10.6 xmirakulix Florian 2010-07-01 10:17:09 PDT
                     Re: FSVS on Mac OS X 10.6 pmarek P.Marek 2010-07-01 11:38:54 PDT
                         Re: FSVS on Mac OS X 10.6 xmirakulix Florian 2010-07-01 14:29:40 PDT
                             Re: FSVS on Mac OS X 10.6 pmarek P.Marek 2010-07-01 23:10:35 PDT
Messages per page: