Login | Register
My pages Projects Community openCollabNet

Discussions > users > Re: fsvs error message "Couldn't find a working copy with matching base"

fsvs
Discussion topic

Back to topic list

Re: fsvs error message "Couldn't find a working copy with matching base"

Author pmarek
Full name P.Marek
Date 2011-08-01 10:33:49 PDT
Message Hello Hugh!

On Monday 01 August 2011 Miller, Hugh wrote:
> > Could you please do a
> >
> > realpath $FSVS_CONF/*/_base
> >
> > and
> >
> > fsvs info -d
> >
> > in the WC root, and one directory below, and send me the results?
> > (Privately, if you prefer.)
>
> Unfortunately I don't think I can meaningfully do those checks.
Is it possible that the new automounter changed the name of the mounted
directories, eg. from /media/usb-stick to /media/sdb1 or something like that?
This could explain the change in behaviour.

The _base symlink might just be working because the automounter provided
aliases/symlinks for alternative names, too?


> To get things working, after a bit of experimenting with a small test
> repository, I removed the conf folder completely, then re-ran "fsvs urls
> ...". I was then able to run "fsvs sync-repos" and everything came back
> (looks normal, so far). I did this with both repositories.
Well, yes, that's the normal setup/recovery procedure.

 
> There is now no _base symlink. I am using fsvs 1.2.2 and svns 1.6.11.
Yes, that's gone with the last few versions - it just gave problems with
"find" and other tools.


Regards,

Phil

--
Versioning your /etc, /home or even your whole installation?
             Try fsvs (fsvs.tigris.org)!

« Previous message in topic | 4 of 5 | Next message in topic »

Messages

Show all messages in topic

fsvs error message "Couldn't find a working copy with matching base" "Miller, Hugh" <HughMiller at chevron dot com> "Miller, Hugh" <HughMiller at chevron dot com> 2011-07-25 09:21:45 PDT
     Re: fsvs error message "Couldn't find a working copy with matching base" pmarek P.Marek 2011-07-31 09:56:25 PDT
         RE: fsvs error message "Couldn't find a working copy with matching base" "Miller, Hugh" <HughMiller at chevron dot com> "Miller, Hugh" <HughMiller at chevron dot com> 2011-08-01 08:59:08 PDT
             Re: fsvs error message "Couldn't find a working copy with matching base" pmarek P.Marek 2011-08-01 10:33:49 PDT
                 RE: fsvs error message "Couldn't find a working copy with matching base" "Miller, Hugh" <HughMiller at chevron dot com> "Miller, Hugh" <HughMiller at chevron dot com> 2011-08-01 11:21:56 PDT
Messages per page: