Login | Register
My pages Projects Community openCollabNet

Discussions > users > RE: Unable to compile fsvs

fsvs
Discussion topic

Back to topic list

RE: Unable to compile fsvs

Author "Worley, Chris B" <chris dot b dot worley at intel dot com>
Full name "Worley, Chris B" <chris dot b dot worley at intel dot com>
Date 2007-06-25 12:46:15 PDT
Message I've got all the packages.

There was one error in the Makefile, and a bunch of missing include and
libs that needed referenced, and I was able to compile it.

The error was:

I replaced:

INCS := $(foreach dir, $(INCDIRS), -idirafter $(dir))

...with:

INCS := $(foreach dir, $(INCDIRS), -I$(dir))

The missing headers/libraries were solved with:

INCDIRS := /usr/include/pcre/ /usr/include/gdbm/ /usr/local/include
/usr/include /openpkg/include /usr/local/include/
/usr/local/apr/include/apr-0/
...
FSVS_LDFLAGS = $(LDFLAGS) -L/usr/local/lib -lsvn_subr-1 -lsvn_ra-1
-lsvn_client-1 -lsvn_delta-1 -L/usr/lib64 -lpcre -lgdbm
-L/usr/local/apr/lib -lapr-0 -laprutil-0 -L/usr/local/lib -lsvn_ra-1
-lsvn_client-1 -lsvn_ra-1 -L/usr/local/lib -lsvn_ra-1
...
        $(CC) $(LDLIBS) $(FSVS_LDFLAGS) -o $@ $^ -L/usr/local/lib
-lsvn_ra-1 -lsvn_client-1 -lsvn_ra-1 -lsvn_ra_dav-1 -lsvn_ra_local-1
-lsvn_ra_svn-1 -lneon

>-----Original Message-----
>From: Thomas Harold [mailto:tgh at tgharold dot com]
>Sent: Monday, June 25, 2007 1:40 PM
>To: users at fsvs dot tigris dot org
>Cc: Worley, Chris B
>Subject: Re: Unable to compile fsvs
>
>Worley, Chris B wrote:
>> The fsvs README says just run "make" (after cd'ing to src). That
didn't
>> work, so I ran "./configure"... same issues... can't find header
files.
>> It looks like I need to hook it into the subversion source tree, so I
>> tried some CFLAGS w/ "-I" to subversion directories... still no joy.
>>
>> Any ideas?
>>
>> This is an RHEL4U4 distro. Subversion built and installed w/o error.
>
>Looks like you're missing some packages. Here's the note from my blog
>about installing on CentOS5 - I'd assume that it will (mostly) apply to
>RHEL4.
>
>In order for the install to succeed, you must have installed the
>"subversion", "subversion-devel" "apr", "apr-devel", "gcc" and "ctags"
>packages. Two others that you need are "gdbm" and "pcre" (and the
>associated developer packages). There may be other dependencies that
>will also be installed that are required by those packages. The
>following command worked for me on CentOS5:
>
># yum install subversion subversion-devel ctags apr apr-devel gcc gdbm
>gdbm-devel pcre pcre-devel

« Previous message in topic | 3 of 4 | Next message in topic »

Messages

Show all messages in topic

Unable to compile fsvs "Worley, Chris B" <chris dot b dot worley at intel dot com> "Worley, Chris B" <chris dot b dot worley at intel dot com> 2007-06-25 11:24:50 PDT
     Re: Unable to compile fsvs Thomas Harold <tgh at tgharold dot com> Thomas Harold <tgh at tgharold dot com> 2007-06-25 12:40:25 PDT
         RE: Unable to compile fsvs "Worley, Chris B" <chris dot b dot worley at intel dot com> "Worley, Chris B" <chris dot b dot worley at intel dot com> 2007-06-25 12:46:15 PDT
             Re: Unable to compile fsvs Thomas Harold <tgh at tgharold dot com> Thomas Harold <tgh at tgharold dot com> 2007-06-25 13:20:58 PDT
Messages per page: