Login | Register
My pages Projects Community openCollabNet

Discussions > users > Cross Sync Problem.

fsvs
Discussion topic

Back to topic list

Cross Sync Problem.

Author KC Laxton <klaxton at brightcove dot com>
Full name KC Laxton <klaxton at brightcove dot com>
Date 2008-01-11 10:05:19 PST
Message Good Afternoon, or <Generic Time Zone Greeting> if it isn't afternoon wherever you are.

I have a slight issue, and googling and reading the archives of the mailing list haven't presented a solution to me. My apologies in advance if my search-fu is just weak.

I have two SVN archives in two different facilities. I use FSVS, as I need to preserve permissions and ownership of these files. I've set up a SSH tunnel from machine1 to machine2 as follows:

[me@machine1]$ fsvs urls dump
N:local,P:100,file:/​//pub/svn/repository​
N:remote,P:200,svn+s​sh://localhost/pub/s​vn/repository

[me@machine1]$ /usr/bin/ssh -o BatchMode=yes -N -L 2222:machine2:22 intermediary_machine

[me@machine1]$ cat .ssh/config
ServerAliveInterval 60

host localhost
    Hostname localhost
    Port 2222

I can confirm the tunnel, and tcpdump the traffic when I make a remote call - The tunnel doesn't appear to be a problem.

[me@machine1]$ ssh localhost hostname
machine2

Now, the two machines will be MOSTLY the same information. Machine 1 will be the primary, with machine 2 being the source of two directories worth of information.

It's my understanding that I should be able to run fsvs sync-repos and then commit, which should sync my repositories. So long as I don't overlap areas being changed, I should be able to commit and have two repositories that are fully in sync.

My problem is that a commit after the fsvs sync-repos does not attempt to update machine2. I get this:

[me@machine1]$ fsvs sync-repos

[Lots of file information]
sync-repos for file:///pub/svn/repository rev 1.

f..C. dir .
sync-repos for svn+ssh://localhost/​pub/svn/repository rev 8.

[me@machine1]$ fsvs commit -o commit_to=remote -m "Testing"
Committing to svn+ssh://localhost/​pub/svn/repository
committed revision 9 on 2008-01-11T17:50:28.600098Z as me

But when I log into machine2:
[me@machine2~]$ svnlook tree /pub/svn/repository/
/

I see nothing.

Any ideas?

Thanks in advance!
Attachments

« Previous message in topic | 1 of 4 | Next message in topic »

Messages

Show all messages in topic

Cross Sync Problem. KC Laxton <klaxton at brightcove dot com> KC Laxton <klaxton at brightcove dot com> 2008-01-11 10:05:19 PST
     Re: Cross Sync Problem. pmarek P.Marek 2008-01-11 10:36:41 PST
         RE: Cross Sync Problem. KC Laxton <klaxton at brightcove dot com> KC Laxton <klaxton at brightcove dot com> 2008-01-11 11:00:31 PST
             Re: Cross Sync Problem. pmarek P.Marek 2008-01-12 00:58:46 PST
Messages per page: